Win11切换到旧版右键菜单:

reg add "HKCU\Software\Classes\CLSID{86ca1aa0-34aa-4e8b-a509-50c905bae2a2}\InprocServer32" /f /ve

恢复回Win11右键菜单:

reg delete "HKCU\Software\Classes\CLSID{86ca1aa0-34aa-4e8b-a509-50c905bae2a2}" /f

重启Windows资源管理器生效。

taskkill /f /im explorer.exe & start explorer.exe

写成BAT,如下

echo Win11切换到旧版右键菜单:

    reg add "HKCU\Software\Classes\CLSID{86ca1aa0-34aa-4e8b-a509-50c905bae2a2}\InprocServer32" /f /ve

echo 重启Windows资源管理器生效。

    taskkill /f /im explorer.exe & start explorer.exe

不需要密码删除 亚信安全officescan
因为杀毒软件损坏,需要修复性重装,但是又报错
趋势官网不提供删除工具,需要找技术支持,CUT工具每个季度会更新
百度一下,找到这个结果

一定要在 安全模式 下运行
进入安全模式
Win7以前进系统前按F8
Win10及以后在 更新和安全--恢复--高级启动 里进入安全模式

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\TrendMicro\PC-cillinNTCorp\CurrentVersion\Misc.]
"Allow Uninstall"=dword:00000001

进入注册表

HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\TrendMicro\PC-cillinNTCorp\CurrentVersion\Misc.

将Allow Uninstall的值 0 改为 1

然后在 安全模式 下,不需要密码直接卸载 officescan

删除残留文件,重新安装

Although WordPress can work in almost any environment, even very minimal ones, it must be acknowledged that it does not work completely well in these. That’s why here we are going to make some minimum recommendations of the environment in which it would work most effectively.

https://make.wordpress.org/hosting/handbook/server-environment/

Web Server #Web Server
The web server is the software dedicated to run the files of the website and where users come to consult them, mainly through the Web.

There are many web servers and, generally, any that support the execution of PHP files should be able to work with WordPress.

When it comes to the server, web, WordPress officially supports:

Apache HTTPD 2.4
nginx 1.20 / 1.19
http://nginx.org/download/nginx-1.21.3.tar.gz
Also, checked or used by hosting companies and developers:

LiteSpeed Web Server 6.0 / 5.4 / 5.3
OpenLiteSpeed 1.7 / 1.6 / 1.5 / 1.4
WordPress may work with older versions, but we recommend only versions that are stable and supported.

Remember that if you have a website running in production, it is recommended to use the latest stable version of each of the web servers (mainly for security, rather than functionality), but not alpha, beta or candidate (RC) versions.

PHP #PHP
PHP is a programming language on which WordPress code is based. This language runs on the server and it is important to keep it up to date, both for security and functionality.

WordPress supports many versions of PHP, some even obsolete, but as a general rule you should use only those with security or stable support.

Officially the WordPress core supports from PHP 5.6.20 to PHP 8.0. However, not all themes or plugins are supported.

When it comes to PHP, WordPress works best with the following versions:

PHP 8.0
PHP 7.4
https://www.php.net/distributions/php-8.0.11.tar.gz
https://www.php.net/distributions/php-7.4.24.tar.gz

必须安装扩展
curl,dom,exif,fileinfo,hash,imagick,json,mbstring,mysqli,openssl,pcre,sodium,xml,zip,
推荐安装扩展
bcmath,filter,gd,iconv,intl,mcrypt,simplexml,xmlreader,zlib,

另外安装服务
ssh2,ftp,sockets,
系统扩展
ImageMagick,Ghost Script

数据库
MariaDB 10.5 / 10.4 / 10.3 / 10.2
MySQL 8.0 / 5.7
https://dev.mysql.com/downloads/mysql/
https://dev.mysql.com/get/Downloads/MySQL-8.0/mysql-8.0.26-1.el8.x86_64.rpm-bundle.tar
https://dev.mysql.com/get/Downloads/MySQL-8.0/mysql-community-server-8.0.26-1.el8.x86_64.rpm

推荐运平台数据库
Amazon Aurora
Amazon RDS for MariaDB
Amazon RDS for MySQL
Google Cloud SQL
Percona MySQL Server 8.0

NGINX
https://www.icode9.com/content-3-1087281.html
http://nginx.org/en/linux_packages.html#RHEL-CentOS

PHP8
https://wvww.cn/15.html

MYSQL
https://www.gaoxiaobo.com/web/server/169.html

systemctl stop firewalld
https://blog.csdn.net/weixin_46106069/article/details/114700217
https://blog.csdn.net/qq_39289155/article/details/111501000

linux服务器nginx安装资源(nginx、openssl、pcre、zlib、gcc、gcc-c++)

./configure --prefix=/usr/local/libiconv

yum -y install wget vim pcre pcre-devel openssl openssl-devel libicu-devel gcc gcc-c++ autoconf libjpeg libjpeg-devel libpng libpng-devel freetype freetype-devel libxml2 libxml2-devel zlib zlib-devel glibc glibc-devel glib2 glib2-devel ncurses ncurses-devel curl curl-devel krb5-devel libidn libidn-devel openldap openldap-devel nss_ldap jemalloc-devel cmake boost-devel bison automake libevent libevent-devel gd gd-devel libtool libmcrypt libmcrypt-devel mcrypt mhash libxslt libxslt-devel readline readline-devel gmp gmp-devel libcurl libcurl-devel openjpeg-devel sqlite-devel net-tools

yum -y install ntpdate gcc gcc-c++ ncurses ncurses-devel cmake readline-devel zlib.x86_64 zlib-devel.x86_64 bison libcurl- net-tool tree nmap sysstat lrzsz dos2unix telnet.x86_64 nethogs iftop iotop unzip ftp.x86_64 xfs expect vim wget psmisc openssh-client libaio libaio1 libnuma openssl-devel bzip2

https://blog.51cto.com/u_15162069/2699925

https://www.gaoxiaobo.com/web/server/169.html


1、首先下载mysql-8.0.26 RPM安装包。

官方rpm包下载地址:https://dev.mysql.com/get/Downloads/MySQL-8.0/mysql-8.0.26-1.el7.x86_64.rpm-bundle.tar

wget https://dev.mysql.com/get/Downloads/MySQL-8.0/mysql-8.0.26-1.el7.x86_64.rpm-bundle.tar

2、解压tar包
tar -xvf mysql-8.0.26-1.el7.x86_64.rpm-bundle.tar

3、安装mysql-common

rpm -ivh mysql-community-common-8.0.26-1.el7.x86_64.rpm

4、安装mysql-client-plugins
rpm -ivh mysql-community-client-plugins-8.0.26-1.el7.x86_64.rpm

5、安装mysql-community-libs
rpm -ivh mysql-community-libs-8.0.26-1.el7.x86_64.rpm

6、安装mysql-community-client
rpm -ivh mysql-community-client-8.0.26-1.el7.x86_64.rpm

7、安装mysql-community-server
rpm -ivh mysql-community-server-8.0.26-1.el7.x86_64.rpm

报错,提示缺少net-tools
error: Failed dependencies:
net-tools is needed by mysql-community-server-8.0.26-1.el7.x86_64

安装net-tools
yum install -y net-tools*

再次执行上述mysql-community-server安装命令,OK了,可以正常安装。

8、启动mysql
service mysqld start

9、mysql8.0版本后,启动时会生成初始密码,在/var/log/mysqld.log日志中,查看初始密码
grep 'temporary password' /var/log/mysqld.log

mysql -u root -p
show databases;
use mysql;

10、登录mysql,修改root用户密码,开启远程登录权限

mysql 8.*修改的密码强度需要包含大小写字母、特殊符号、数字,否则将报错修改失败

alter user 'root'@'localhost' identified by 'password';

use mysql
update user set host = '%' where user='root';
flush privileges;

作者:只是甲
链接:https://www.jianshu.com/p/090e4a055713
来源:简书
著作权归作者所有。商业转载请联系作者获得授权,非商业转载请注明出处。

必须安装扩展
./configure --prefix=/usr/local/php --with-config-file-path=/usr/local/php/conf --enable-curl --enable-dom --enable-exif --enable-fileinfo--enable-hash --enable-imagick --enable-json --enable-mbstring--enable-mysqli --enable-openssl --enable-pcre --enable-sodium--enable-xml --enable-zip --enable-bcmath --enable-filter --enable-gd--enable-iconv --enable-intl --enable-mcrypt --enable-simplexml --enable-xmlreader --enable-zlib--with-pdo-mysql --with-openssl --with-curl --with-gd --with-gettext--with-mhash --with-openssl --with-mcrypt --with-tidy --enable-wddx--with-xmlrpc --with-zlib

2021年 Typecho转换到WordPress
参考文章
https://www.visc.cn/jishu/230.html
步骤 1.导出数据 2.导入数据 3.转换附件
1.ByeTyp这款插件,工作原理是将Typecho中的数据导出为WordPress可识别的WXR文件,然后再用Wordpress的导入工具导入数据
访问ByeTyp项目主页:https://github.com/ibadboy-net/ByeTyp 下载最新版的插件。下载后将插件上传并安装到Typecho上。注意上传的时候要为插件的文件夹命名为ByeTyp,否则插件将无法正常运行。
使用方法
启用插件后,按照以下顺序操作,导出当前Typecho的数据。
控制台-数据导出-导出XML文件
工具-导入-WordPress-运行导入器(未安装的话就先安装)-选择文件-上传并导入-选择导入的文章所属的用户,之后提示是否导入媒体,随便点就行
迁移附件
将Typecho站点中的/usr/uploads目录下面的文件转移到WordPress的/wp-content/uploads目录下。之后在数据库中替换图片资源路径,执行以下SQL语句:
UPDATE wp_posts SET post_content = REPLACE( post_content, '/usr/uploads/', '/wp-content/uploads/');
这样,整个之前Typecho站点的数据都转移到Wordpress系统下了

注意事项
安装要FTP权限,设置目录777,危险性太大了.设置完,马上还原
要么用WINSCP传输文件,手动安装wordpress-importer
https://wordpress.org/plugins/wordpress-importer/
可能是某个组件或者权限没有设置好,编辑无法正常显示
安装 Kindeditor For WordPress
https://wordpress.org/plugins/kindeditor-for-wordpress/
无法发布文章
参见
https://www.shopee6.com/web/web-tutorial/wordpress-this-response-is-not-a-valid-json-response.html

剩下慢慢排查
2021/09/12

1.安装程序时无法连接数据库
在把程序放到目录下,进行安装的时候,将数据库的密码输入正确后,无法进行安装
这个时候处理方式就是手动创建一个typecho的数据库即可解决

2.安装提示无法安装
PHP版本问题,更换PHP版本

3.typecho博客进入不了后台,提示404
https://cloud.tencent.com/developer/article/1142507

Nginx服务器点击前台链接或者后台登录时出现404, not found
官方给的解决方式是一般的出现这种情况时,nginx.conf里的location设置都是类似这样

location ~ .*.php$

要支持pathinfo,要改成

location ~ ..php(/.)*$

在某些老版本的php里面,可能还要打开php.ini里的cgi.fix_pathinfo

cgi.fix_pathinfo = 1

页面404一般都是伪静态的问题,

把enable-php.conf修改为下面这个配置

执行:/etc/init.d/nginx restart 重启生效

nginx下的enable-php.conf配置如下

location ~ .*.php$
{
    #try_files $uri =404;
fastcgi_pass  unix:/tmp/php-cgi.sock;

fastcgi_index index.php;

include fastcgi.conf;

include pathinfo.conf;

}